Samsung TV Fix

I reported a few weeks ago my TV had started going a bit random on me. It would turn itself over to other sources, cycling through TV/PC/HDMI input 1/HDMI input 2 etc very frustrating. In actual fact it has been relatively well behaved and only doing it occasionally for a while. But when you're watching something and it suddenly goes off and you can't get it back on it is more than frustrating.

The Remote had stopped working completely - apart from the On/Off button - and the buttons on the side of the TV were not useful (I could turn on the Menu, but could not select anything from it).

I had looked through pages and pages of issues for Troubleshooting on the net looking for possible issues and fixes and was fearing it was a board/capacitor issue which would end up being either messy or expensive or both. These days it is often as cheap to buy a new TV (or any electrical good) rather than get something fixed.

But today I was lucky enough to find the right page for me; it doesn't help with the Samsung TV naming standards - my TV is snappy titled: LE32B450C4W. Rolls of the tongue that one doesn't it? It's a few years old okay, but my last TV lasted longer and when I started looking into the Samsung issue it is all over the net - but complicated by the naming thing in terms of which problems are common to groups of 'similar' TVs (how can you tell if LE32B..... is similar to LF54Cxxx.... etc? No chance.)

The page I found today was on cnet.com and the specific answer is from 'Kimberley3g' near the bottom of the link. If you've got a similar problem take a look at it. In summary though the issue, which seems widespread, is with the button array at the side of the TV. And the fix... disconnect the little bastards.

TV1

So basically all you need is a screwdriver or two, half an hour and some confidence. I found the screws were easy enough to take out. It was a bit fiddly disconnecting the cables - I tried at both ends. In the end I disconnected the connector on the button board (the other end is on the Infrared board (see pics). The buttons are on the bottom left of the TV (looking from the back) and the connections are to the IR board at the very bottom of the same corner.

Samsung Buttons

Anyway, got it disconnected. Screwed the back and base back on and plugged all the connections back in (satellite, playstation, audio) and crossed my fingers.

Turned the TV on and hey presto! The Remote Control was miraculously working again for the first time for a month or so. The lack of information on the Samsung website and Forums on what is a known issue is very frustrating. I'm pretty sure I won't buy a Samsung TV again (this issue has carried on through to much more recent TVs).

Fingers crossed it continues to work - I suspect it will. I don't know Kimberley but I'll be raising a glass to her tomorrow.

Huzzah!




blog comments powered by Disqus